Battlefield Mod Development Tools

News
About
Tutorials
Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
Contact


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Mod Development Toolkit Version 0.2

This includes all tools and the tutorial site.

Updated: 9-8-2003


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
NEWS

September 4th 2003
Welcome to the Battlefield 1942 Mod Development Toolkit site. Here you can download all the neccesary tools for developing your own mods based on Battlefield 1942 as well as tutorials and examples on how to use these tools. To get started, click on the Tutorials link, How to make a mod section to learn about Battlefield 1942 modding and what the tools do.

Thanks, The Mod Development Toolkit team


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
 Scripting Reference

Downloads
MDT Version .5
Forums
Contact

MDT Video - Exporting models

This video tutorias steps you through the basics of exporting a model.

MDT Video - Exporting Trees

This video tutorial steps you through the basics of exporting trees.


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Tutorial 1 - How to make a mod

This tutorials steps you through the basics of creating your first mod.

Tutorial 2 - How to edit Battlefield 1942 Textures

This tutorial will step you through the editing of Battlefield 1942 textures.

Tutorial 2 - How to edit Battlefield 1942 Models

This tutorial will step you through the editing of Battlefield 1942 models.

Tutorial 2 - How to edit Battlefield 1942 Trees

This tutorial will step you through the editing of Battlefield 1942 trees.

Tutorial 3 - How to edit Battlefield 1942 Tank Treads

This tutorial will step you through the editing of Battlefield 1942 animating tank treads.

Tutorial 4 - How to edit Battlefield 1942 Weapon Animations

This tutorial will step you through the editing of Battlefield 1942 weapon animations.

Tutorial 5 - How to create Handweapons

This tutorial will step you through the creation of new Handweapons in Battlefield 1942.


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

How to Create Handweapons

In this tutorial, you will learn how to modify skeletons and create animtaion

Requirements:
- You have already completed the tutorial on creating a mod with the Mod Wizard.
- 3DS Max 5.


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
 Scripting Reference

Downloads
MDT Version .5
Forums
Contact

Creation of a mod with the mod wizard

In this tutorial, you will learn how to create a new mod for Battlefield.

1. Run the program ModWizard.exe included in the developers kit Tools folder.
2.

For this tutorial we are going to leave the default settings as they are shown in this image:
3.

Press the Finish button and you will be shown a dialog similar to this one. If you are instead shown a dialog that states "Mod with this name already exists", you will need to specify a new name for the mod or delete the mod folder that already exists with that name from your Battlefield/Mods/ directory.
4.

Take note of the location of your new mod's directory and browse to that location with windows explorer. You can now press the OK button to have your new mod created. From now on I will assume that your mod's name is "My_Mod".
5.

Below is a view of My_Mod in windows explorer:
6.

You can see folders named "Objects" and "Texture", those folders are regular files that you can freely edit. To allow the game to use those files when your mod is active you need to package the files into what is called an RFA archive file. To do this we need to browse to the /My_Mod/Archives directory where you will find PackRFA.exe.
7.

Double click on PackRFA.exe, you will see something similar to this image below:
8.

You will see on the right a drop down list with the folder names of "Objects" and "Textures" listed. You can create additional folders along side of "Objects" and "Textures" and they will be listed the next time you run PackRFA.exe. Press "Pack Folder" to pack the currently selected item from that listbox to a .rfa archive file. You can also press the ALL button to pack all items listed to their respective .rfa archive file.
9.

You can now test the mod by loading up Battlefield and under "CUSTOM GAME" choose "My Mod" from the list and press the "ACTIVATE" button. Because we included sample files from the Mod Wizard you will find the Colt Pistol turned into a rapid-fire machine gun with many additional rounds of ammunition per magazine.

-- End of Tutorial --


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
 Scripting Reference

Downloads
MDT Version .5
Forums
Contact

Skeleton and Animation Editing

In this tutorial, you will learn how to modify skeletons and create animtaion

Requirements:
- You have already completed the tutorial on creating a mod with the Mod Wizard.
- 3DS Max 5.

1. Install the 3dsmax toolset from the mod developer's kit by running the 3dsmax toolset installer program.
2.

Load up 3dsmax and you will find a new menu named "Battlefield Tools", choose RFA Tools from the Battlefield Tools menu.
3.

Choose Open .rfa from the File menu
4.

Browse to the /mods/bf1942 folder. The "bf1942" folder has Battlefield's data files for a normal game.
5.

Choose "animation.rfa" and press Open.
6.

Select the file Colt.ske. This file is the colt pistol weapon's skeleton. From the Extract menu choose Selected.
7.

Select the My_Mod folder in the Browse for Folder dialog and press OK.
8.

In 3dsmax choose Skeleton and Skin from the Battlefield Tools menu
9.

Press the Import (.ske) button under Skeleton Inport with IsWeapon checked, and As Boxes checked. Then browse to my_mod/archives/animations/ and select and open the file Colt.ske
10.

Import the .sm models of the colt pistol parts from my_mod and rename the parts to the same names used by the skeleton bones. The names are case sensitive. Then save that scene file with a name. With this scene file still open with the bones, choose file->Replace and select the scene file that has the renamed colt pistol parts. Select all objects for replacing and press ok.
11.

With the acutal models in place you will see something like the screen below:
12.

Animate the object named "mantel" using position and rotation. (Only the position and rotation values can be animated for this game)
Then choose Animation from the Battlefield Tools menu.
13.

Have Is Weapon checked and Use Active Segment checked, then with the mantel part selected, press Export Single .Baf. Note that only selected objects will have animation exported.
14.

Save the file as ColtReload.baf in My_Mod's folder location as shown below:
15.

In /my_mod/archives/ run PackRfa.exe, select animations from the folder drop down list and press the Pack Folder button.
16.

Here is how the new colt reloading animation looks in game (Fire off some rounds and press the "R" key to reload the weapon):
-- End of Tutorial --


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
 Scripting Reference

Downloads
MDT Version .5
Forums
Contact

3D Model Editing (TreeMesh)

In this tutorial, you will learn how to modify models for Battlefield

Models for Battlefield are stored primarily in the standardMesh.rfa archive. The two major formats in use are .sm and .tm.
Tools to import and export Battlefield models were included with the Battlefield mod developer's kit. The tools are written for 3D Studio Max version 5.1

Requirements:
- You have already completed the tutorial on creating a mod with the Mod Wizard.
- You own a copy of 3D Studio Max 5.1 or higher.

1. | Install the 3dsmax toolset from the mod developer's kit by running the 3dsmax toolset installer program.
2.

Load up 3dsmax and you will find a new menu named "Battlefield Tools", choose RFA Tools from the Battlefield Tools menu.
3.

Choose Open .rfa from the File menu
4.

Browse to the /mods/bf1942 folder. The "bf1942" folder has Battlefield's data files for a normal game.
5.

Choose "treeMesh.rfa" and press Open.
6.

Select the file PALMHIGH_M1.tm. This file is of a tree used frequrently on the Wake Island map. From the Extract menu choose Selected.
7.

Select the My_Mod folder in the Browse for Folder dialog and press OK.
8.

In 3dsmax choose Tree Import/Export from the Battlefield Tools menu
9.

Press the IMPORT... button under TreeMesh Import and browse to /My_Mod/TreeMesh/
10.

Select "PALMHIGH_M1.tm" and press Open
11.

Here is how the model looks imported into 3dsmax.
12.

Set modify mode and sub object vertex on the palmhigh_m02 object. Then use the selection and scale too to deform the mesh into an odd shape. This is so we can see that we have changed the model in game.
13.

Goto the export treemesh screen from Battlefield Tools. Press Pick Collision and pick COL_treemesh as your collision model.
14.

Press Add Branch and pick palmhigh_m02. This geometry will be rendered as a tree branch with its transparency effects.
Press Add Trunk and pick palmhigh_m03 and Add Trunk palmhigh_m04. This trunk geometry will be rendered as regular geometry.
Take note that you can have only one material per object with the current treemesh export version.

Have Force Material ID checked and set to Material ID 166, you can find more values to use by either importing existing .tm files or looking in the /bf1942/game/ archive folders and then at .con files material in their names.

Press Export .tm and choose the existing file named "PALMHIGH_M1.tm"
15.

Press yes to the dialog box that pops up to overwrite the existing file
16.

We are going to render the billboard for the modified tree. To do this select palmhigh_m02, palmhigh_m03 and palmhigh_m04 then press Render Billboard with the spinner value of 128 for the image resolution. If you want to, you can create your own lights but if no lights are found in the scene, the exporter will create a default set for you.

If you are using alpha channels for transparency then you want to have the opacity map in the material set to the same texture only with the alpha channel set (see 3dsmax user refernce for how to setup an opacity map). It should also be noted that the .dds plugin for 3dsmax that was used for this tutorial did not support reading of alpha channels. Converting the .dds to a 32bit .tga file worked around this issue. All this is necessary if you wish to have a billboard rendered with proper transparency for parts of the treemesh that use alpha channels for transparency.

Press the Save Bitmap button on the rendered image dialog.
17.

Create a subdirectory named Billboards inside /My_Mod/treeMesh/ and save the image with the same name as the treemesh you exported. Here we use "PALMHIGH_m1.tga". Use 32bit with alpha channel and save as a .tga (targa).
18. | Convert the .tga file to a .dds (DXT 5) texture then delete the .tga file
19.

In /my_mod/archives/ run PackRfa.exe, select treeMesh from the folder drop down list and press the Pack Folder button.
20.

Here is how the new model looks in game:
-- End of Tutorial --


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
 Scripting Reference

Downloads
MDT Version .5
Forums
Contact

2D Texture Editing

In this tutorial, you will learn how to modify textures for Battlefield

Textures for Battlefield are stored primarily in the textures.rfa archive. The two major formats in use are .dds and .tga.
You can download tools to convert to and from the .dds (DXTC) format from this webpage:
http://developer.nvidia.com/object/ps_texture_compression_plugin.html
A simple method for saving and loading .dds files is to download the Photoshop plug-in available from the previously stated webpage and use Photoshop's file>open and file>save menu commands with the .dds DXTC format selected as the image type. This is the method I will be using in tutorial below.

Requirements:
- You have already completed the tutorial on creating a mod with the Mod Wizard.
- You own a copy of Adobe Photoshop.
1. Install the plug-in for dds textures to C:\Program Files\Adobe\Photoshop\Plug-Ins\File Formats\dds.8bi
2.

Load up Photoshop and from the File menu choose Open, then browse to the Texture folder of My_Mod.
3.

Open the file named "SampleTexture.dds"
4.

Here you see the file "SampleTexture.dds" loaded into Photoshop:
5.

From the File menu choose Save As...
6.

Type in "Colt_o.dds" as the File name and press the Save button
7.

Have these settings set shown in the image below and press the Save button.
8.

Here is the colt pistol with it's modifed texture in game:

-- End of Tutorial --


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
 Scripting Reference

Downloads
MDT Version .5
Forums
Contact

Skin Editing

In this tutorial, you will learn how to create new skin files to bind geometry to skeletons

Requirements:
- You have already completed the tutorial on creating a mod with the Mod Wizard.
- 3DS Max 5
1. Install the 3dsmax toolset from the mod developer's kit by running the 3dsmax toolset installer program.
2.

Load up 3dsmax and you will find a new menu named "Battlefield Tools", choose RFA Tools from the Battlefield Tools menu.
3.

Choose Open .rfa from the File menu
4.

Browse to the /mods/bf1942 folder. The "bf1942" folder has Battlefield's data files for a normal game.
5.

Choose "animation.rfa" and press Open.
6.

Select the file sherman_trackL_m1.skn and shermanTrackL.ske. From the Extract menu choose Selected.
7.

Select the My_Mod folder in the Browse for Folder dialog and press OK.
8.

In 3dsmax choose Skeleton and Skin from the Battlefield Tools menu
9.

Press the Import (.ske) button under Skeleton Inport with IsWeapon unChecked, As Boxes checked and Bone Size set to 300%. Then browse to my_mod/archives/animations/ and select and open the file shermanTrackL.ske
10.

Import Sherman_trackL_M1.sm from the game's standardmesh.rfa file
(extract the file from mods/bf1942/archives/standardmesh.rfa to mods/my_mod/)
11.

Select all vertices in the tank tread mesh and scale on the X-Axis so that in game we can see a change.
12.

Export the modified tank track to /my_mod/standardMesh/Sherman_TrackL_M1.sm
13.

With the tank track selected, goto Modifiers->Animation Modifiers->Skin. Then press Add under Parameters and select bone0 through bone5.
Note: You will want to move the bones upwards to move the tank tread downwards in-game, do this movement prior to adding the .skn modifier.
14.

With sub-object Envelope selected, select each bone from the list and adjust the envelope gizmo as needed. Vertices that turn red are ones that will be affected by that bone. You may also choose to paint weights instead. See paint weight options and button further down below Envelope Properties.
15.

When your weights have been setup you will need to export the .skn file that stores these weights. In the Ske/Skn dialog choose export .skn with the tank tread selected. Save the file as /My_Mod/Animations/sherman_TrackL_M1.skn
16.

In /my_mod/archives/ run PackRfa.exe and press the All button at the right side of the window.
17.

Here is how it looks in game:
You can adjust the offset position of the tank tread by moving the skeleton bones inside 3dsmax prior to adding the skin modifier. Do so if you see wheels going through the tread itself.
-- End of Tutorial --


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
 Scripting Reference

Downloads
MDT Version .5
Forums
Contact

3D Model Editing

In this tutorial, you will learn how to modify models for Battlefield

Models for Battlefield are stored primarily in the standardMesh.rfa archive. The two major formats in use are .sm and .tm.
Tools to import and export Battlefield models were included with the Battlefield mod developer's kit. The tools are written for 3D Studio Max version 5.1

Requirements:
- You have already completed the tutorial on creating a mod with the Mod Wizard.
- You own a copy of 3D Studio Max 5.1 or higher.

1. Install the 3dsmax toolset from the mod developer's kit by running the 3dsmax toolset installer program.
2.

Load up 3dsmax and you will find a new menu named "Battlefield Tools", choose RFA Tools from the Battlefield Tools menu.
3.

Choose Open .rfa from the File menu
4.

Browse to the /mods/bf1942 folder. The "bf1942" folder has Battlefield's data files for a normal game.
5.

Choose "standardMesh.rfa" and press Open.
6.

Select the files Colt_base_m1.rs and Colt_base_m1.sm. These files are part of the colt pistol weapon. The .rs text file containing shader information as show in the window below, the .sm file is the geometry data file that contains the mesh data.
From the Extract menu choose Selected.
7.

Select the My_Mod folder in the Browse for Folder dialog and press OK.
8.

In 3dsmax choose Model Import/Export from the Battlefield Tools menu
9.

Press the Import button under 3D Models to bring up the Mesh Import dialog screen. Set your options to Only Main LOD/Mesh, Visible, and Shadow then press the IMPORT... button.
10.

Browse to the /My_Mod/standardMesh directory.
11.

Select "Colt_Base_m1.sm" and press Open
12.

Here is how the model looks imported into 3dsmax.
13.

Set modify mode and sub object vertex on the LOD01_colt_base_m1 node. Then use the selection and scale too to deform the mesh into an odd shape. This is so we can see that we have changed the model in game.
14.

Goto the export 3d model screen and press Add LOD, then pick the LOD01_colt_base_m1 node. This is the primary visible model. Check Auto Generate LODs and set the Min # of LODs spinner to 6, this will tell the exporter to generate 5 additional meshes of progressively lower detail to use. LOD meshes are used to increase game performance by switching to lower detail versions of the primary visible model when the camera is further away from the object.

Make sure Simple Shader is unchecked if you wish to have all the material settings exported.

Pick the Colt_base_m1_ node as the shadow geometry. This model will be used to cast real-time 3d shadows onto the terain while in game.

You can now press the export button and choose the existing Colt_base_m1.sm file inside My_Mod/Standard mesh as the filename.
15.

Press yes to the dialog box that pops up to overwrite the existing file
16.

In /my_mod/archives/ run PackRfa.exe, select standardMesh from the folder drop down list and press the Pack Folder button.
17.

Here is a screen shot of the My_Mod/Archives directory with the file archive standardMesh.rfa packed.
18.

Here is how the new colt model looks in game:
-- End of Tutorial --


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

MDT - Standard Mesh Export

This tutorials steps you through the basics of creating your first mod.

MDT - Standard Mesh Import

This tutorial will step you through the editing of Battlefield 1942 textures.

MDT - Treemesh Export

This tutorial will step you through the editing of Battlefield 1942 models.

MDT - Animation Import/Export

This tutorial will step you through the editing of Battlefield 1942 models.

MDT - Skeleton and Skin Import/Export

This tutorial will step you through the editing of Battlefield 1942 models.


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Tree Mesh Export/Import

Tree Mesh Export Group

Pick Collision: Pickbutton for designating a collision mesh.
Add Branch: Adds geometry rendered as a branch to the treemesh file to be exported
Add Trunk: Adds geometry rendered as a trunk to the treemesh file to be exported
Add Sprite: Adds geometry rendered as a sprite to the treemesh file to be exported
Force Material ID: When checked, the material ID specified will be used instead of per face material IDs of the collision mesh.
Material ID: Specifies the value to use as the material ID when forcing the collision mesh to a single value.
Remove Item: Removes the selcted item from the listbox.
Scale: Adjusts the size of the model
Export .tm: Exports a .tm file

Tree Mesh Import Group

Scale: Adjusts the size of the model
IMPORT ...: Imports a .tm model

Billboard Rendering Group

Resolution: Adjusts the output height resolution of the billboard. (128 is typical)
Render Billboard: Renders the selected object to a billboard image to be saved as the .tm filename and into the treemesh\billboards\ directory.


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Standard Mesh Import

Mesh Information Group

Get polycount of .sm: Displays information about a .sm file in the listbox below.
Clear: Clears the contents of the listbox below.

Mesh Import Group

Only Main LOD/Mesh: Imports only the highest detail mesh of the collision and visible model sets.
Detach Materials: The imported mesh will have materials as seperate objects rather than using one mesh object with multiple materials.
BoundingBox: A box will be created to represent the bounding box coordinates stored in the .sm file
Collision: Any collision models present in the file will be imported.
Visible: Any visible models that you would see in game will be imported.
Shadow: If a shadow mesh is present, it will be imported.
Scale: Adjusts the size of the imported models.
IMPORT ...: Imports a .sm file with the options set.


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Standard Mesh Export

Visible Level of Detail Meshes Group

Auto Generate LODs: When checked, creates lower detail versions of your first visible mesh to switch to at further distances.
Min # of LODs: Specifies the minimum number of models to generate for LOD switching.
Add LOD: Adds a scene geometry object to the list of LOD meshes. The first mesh in the list will be visible closest to the camera where as the last mesh in the list will be visible furthest from the camera in game.
Remove: Removes the selected LOD mesh entry from the listbox.

Collision Mesh Group

Low Detail: Pickbutton designation of a collision mesh used for low detail collision tests. (Terrain geometry)
High Detail: Pickbutton designation of a collision mesh used in game for high detail collision tests. (Other objects, bullets etc..)
BSP Optimization: Use this setting checked to optimize collision mesh performance of larger models. A binary space partition tree will be generated that allows only near parts of the model to be tested for hits rather than the entire model.
Force MatID: Uncheck this to use the existing material ID values set on the collision mesh object faces. Leave checked if you wish to use the MatID override value below.
Drop Down list: Select a pre-defined material ID value by name from this list.
Material ID spinner: Sets the material ID value to use for the entire hitbox mesh. These values are used for different armor types and different effects. Only active if Force MatID is checked.

More Options Group

Lightmapped: Allows the exported geometry to make use of lightmaps. (Tip: A lightmapped model will have more hard edges between adjoining faces.)
Simple Shader: When checked advanced material settings are ignored except the texture file name. When unchecked, 2-sided, specular color, diffuse color, and more options may be used.
Scale: Adjusts the size of the exported model.
Custom BBox: Pickbutton designation of a custom bounding box scene object. The bounding box is used to determine clipping distances of objects visible mesh as well as physics balancing. You may use any object in the scene as the custom bounding box.
Shadow Mesh: Pickbutton designation of a scene geometry to be used in casting real-time 3d shadows onto the terrain. Used for vehicle parts. Note: Player model shadows are generated from the visible model.

Export: Saves the .sm and .rs files, prompting for the name and location first.


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Skeleton/Skin Import/Export

Skeleton Import Group

As Boxes: When checked, bones will be represented with boxes instead of standard bones.

Bone Size %: Adjusts the display size of the imported bones. This setting does not adjust the positional scale, just the size of the bone object so you can see it better.

Import (.ske): Prompts for a .ske file from which to import the skeleton into the scene. Use the IsWeapon checkbox if importing a weapon skeleton.

Other Groups

Skeleton Export - Export (.ske): Saves a .ske file containing the selected bones. Any object may be used as a bone so make sure to only select the ones you wish to include in the skeleton. Use the IsWeapon checkbox if exporting a weapon skeleton.

Skin Export - Export (.skn): Saves a .skn file for the selected object in scene. The selected object must have a skin modifier to export.

IsWeapon: Use this setting when importing a weapon skeleton. Weapon skeletons will be much easier to edit when imported and exported with IsWeapon checked.


Battlefield Mod Development Tools

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Animation Import/Export

Animation Sequences Group

Add Sequence: Adds an animation sequence to the listbox of sequences for exporting to multiple animation files. Adding a sequence uses the current prefix and name text along with the start frame and end frame spinner values.

Remove Sequence: Removes the selected imem from the sequence list box..

Clear Sequence: Clears the listbox of sequences.

Save Sequence: Saves list file of sequence names, with start frame and end frame timeline settings for later use.

Load Sequence: Loads a saved list file of sequence names, with start frame and end frame timeline settings.

Start: Set the start frame for this current animation segment.

End: Set the end frame for this current animation segment.

Use Active Segment: This option is used when exporting a single .baf file, the current time start and end frames will be taken from the scene's current start and end frame.

Export Single .Baf: With the only the bones you have animated selected, press this button to save out a single .baf animation file. Start and End time values are taken from the spinners with the same names or from the scene's current timeline settings if Use Active Segment is checked.

Output Group

Directory: Specifies the output directory location for the .baf files to be saved when Generate Sequence is pressed..

Browse: Brings up a browse for directory location dialog for specifing where the .baf files are to be saved when Generate Sequence is pressed.

Generate Sequence: Starts the export process saving multiple .baf files from one .max scene file. Only the selected bones' animations will be exported to each .baf file.

Other Settings

Import .baf: Press this button to import a .baf animation file. Have in your scene, the skeleton that will be animated prior to importing the .baf and that skeleton will be given the imported animation. After importing a .baf animation file the bones that were animated will be selected. It is wise to create named selection set of these imported bones so that exporting will be easier. See your 3d animation product's documentation on named selection sets for more information.

Is Weapon: Check this option if Importing or Exporting a weapon animation.

Prefix: This text box is used when you press the Add Sequence button for setting up multiple animation files to export. The text in this box will be placed before the name. For example: if the name is "walk" and prefix is "lowerBody" then when Add Sequence is pressed the result will be "lowerBodyWalk". The file would be then saved as lowerbodyWalk.baf when Generate Sequence is pressed.

Name: This text box is used when you press the Add Sequence button for setting up multiple animation files to export. Type in a name here to be used as the filename for the sequence. For example: use "walk" and the file will be saved as walk.baf when Generate Sequence is pressed.


MDT Documentation - Main

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Battlefield 1942 Scripting Guide

Here you will find topics covering all the different files Battlefield 1942 uses, and what you can do with them.

TOPICS

1. Introduction to Modding Battlefield 1942 - Explains what a mod is, and kind of things you can do with the Battlefield 1942 game engine.

2. RFA Files - Explains how Battlefield 1942 uses compressed RFA files to store game data, and how to extract / re-compress them.

3. CON Files - This section covers the Battlefield 1942 console scripting language.

4. Models and Textures - Information and instructions for importing custom models and graphics to Battlefield 1942.

5. Animation - Explains the Battlefield 1942 animation system, and how to use custom animations.

6. Maps - Overview of all the different files used for battlefield 1942 maps.

7. Menu System - Information on using the Battlefield 1942 Menu system.


MDT Documentation - RFA - Intro

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Introduction to RFA files

Disscuss what an RFA file is, what programs are necessary for extraction / compression. List all the different types of RFA files included in BF (objects, textures, standardmesh, game, etc..) explain what each type is for, and the necessary directory structure.


MDT Documentation - Models & Textures - Intro

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Models and Textures in Battlefield 1942

Models - explain the parts in battlefield model files (SM) Visible meshes, Collision meshes, Lod Meshes, Bounding boxes. Also Go over materials, and how the collision mesh uses materials (link to material page)

RS files - explain the render settings in the RS files (texture path, transparency, chrome, etc..)

Texture files - Go over the dds format (mip-maps, alpha, DXT1 / DXT3) and TGA format (alpha)

make sure to have links back to the relevant RFA information... (texture, standardmesh)


MDT Documentation - Intro to Modding

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Introduction to Modding Battlefield 1942

Disscuss what a mod is, (custom game), and what kind of things you can do with a mod. General introduction stuff here.


MDT Documentation - CON - Intro

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Console Scripting and Objects in Battlefield 1942

.CON files are really what brings everything together in Battlefield 1942. Con files link together the objects, models, sounds, maps, AI, and settings in the game.

Typically, the most .con files you'll want to modify or create will be in the Objects.rfa archive file. Once this is extracted you'll find this directory structure:

Vehicles/ | - All the cars, jeeps, tanks, planes, and boats.
Common/ | - a few very common items.
Buildings/ | - static building objects, with the decoration layout information.
Effects/ | - explosion, dust, water ripples, and other cosmetic effects.
Handweapons/ | - weapons that the player carries with them and keeps in their inventory
Items/ | - flag and kit (weapons per class) information.
MOVE_FILES/ | - static scenery pieces, chairs, tables, pipes, logs, signs, etc...
Soldiers/ | - soldier properties, sounds, parts (hands, heads, body's)
Stationary_weapons/ | - mounted machine guns.
Vegitation/ | - trees and bushes.

These directories are broken down into more sub-directories for organization until the actual .con files are reached. The objects are usually seperated into multiple con files, and they are organized by function:

Objects.con - Most misc objects, like SimpleObjects, Bundles, PlayerControlObjects, and RotationalBundles.

Physics.con - Objects with Physical reactions, like Wings, Engines, Springs, and FloatingBundles.

Weapons.con - Weapons releated objects, like HandFireArms, FireArms, and Projectiles.

Network.con - Contains all the NetworkableInfo's for Multi-player compatibility.

Effects.con - Effect Related objects, like Particles, Emitters, EffectBundles.

Geometry.con - Contains all the GeometryTemplates that link to .sm model files.

*AI/Objects.con - Artifical Intelligence information so that bots can interact with the object.

Other .CON Files

* go over the con files in game.rfa, and other misc .con files not found in objects.rfa

.CON Data types, coordinates, and constants

* go over the x/y/z coordinates, rotation coordinates, data types (like float, boolean, degree's), and constants (engine types, input values)

Reference Information

This is a list of all the .con commands

GeometryTemplate - explain the different geometry types, and properties, and how it relates to the .sm / .rs file.

ObjectTemplate - (this is the big chapter) explain what the different object types are, and the properties for each object type. (covers buildings, pco's, physics, weapons, effects, soldiers.)

NetworkableInfo - explainlain how to use network info's for objects.

MaterialManager - explain how to use materials to adjust damage / defense and effects.


Battlefield Mod Development Tools - Scripting - Objects.con

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Objects.con

Objects.con is probably the most common .CON file in Battlefield 1942. In here you will find most common object types. Basic objects will usually just have an objects.con and *geometry.con, with only the most complex vehicles having all the different types of files.

Most Object.cons contain several objectTemplate commands to define objects, and occasionally a *LodSelectorTemplate for objects that have multiple visible states (cockpits, etc)

Typical Object Types found in Objects.con

AnimatedBundle | - Animated object (ex: Tank tracks)
Bundle | - used for containing many child objects (ex: tank body)
Camera | - specefies player camera view in PlayerControlObjects
EntryPoint | - defines the area where a player can enter a PlayerControlObject
LandingGear | - object that moves based on engine speed and height
LodObject | - object used for switching views in objects (ex: cockpit views, destroyed view)
ObjectSpawner | - creates or "spawns" other objects while ingame (ex: landing craft on carriers)
Obstacle | - Players can move through it, can damage depending on material (barbwire)
PlayerControlObject | - any object a player can enter and take over (vehicles, mounted guns)
RotationalBundle | - object that can pivot in multiple directions (turrets, steering wheels)
SeatObject | - object that can hold a player model, while in a vehicle
SimpleObject | - basic object, used for displaying a single model that doesn't need to move
SonarObject | - Displays radar/sonar in mini-map
SupplyDepot | - refuel / heal vehicles and players


Battlefield Mod Development Tools - Con Guide - Weapons.con

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Weapons.con

The weapons.con file contains all the weapons related objectTemplates. Occasionally, it will contain a *LodObject for first person weapons views, or animation commands.

FireArm | - Vehicle or stationary weapon. This controls the amount of ammo, type of ammo, fireing rate, velocity, etc.
HandFireArm | - Similar to fireArm, but has additional properties for runnin and jumping deviation, as well as animation.
Projectile | - the actual bullet, or bomb, etc generated by the fireArm / handFireArm.


Battlefield Mod Development Tools - Con Guide - Physics.con

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Physics.con

Physics.con files contain objectTemplate physics objects. These are the objects that react to the environent, like terrain, air, and water. This file is usually only found in vehicle directories, but there are some weapons that have physics objects, like rockets, torpedos, and bombs.

Engine | - generates thrust
FloatingBundle | - floats in water, for ships, submarines, and torpedos
Spring | - rolls over ground, for wheels and tank tracks.
Wing | - generates lift as its speed increases, for planes, rockets, and bombs


Battlefield Mod Development Tools - Con Guide - Network.con

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Network.con

This file contains all the networkableinfos for the objects in the directory. Any object that can move, be destroyed, or change states (flags) need to have a network.con for multi-player compatiblity.

see the *networkableInfo command for more information.


Battlefield Mod Development Tools - Con Guide - Effects.con

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Effects.con

This file contains all the explosions, ricochet effects, water ripples, dust clouds, and any other cosmetic effects. These files are all usually kept in the Effects/ folder, becuase they are usually called by many different objects or *material collisions. All the commands in this file are objectTemplate effect related types.

Bundle | -simple multi-part object, used in effects for big pieces of destoyed vehicles (like plane wings)
EffectBundle | -main effect object, usually contains the sound and links to the other objects.
Emitter | -generates particles and SpriteParticles
Particle | -3d effect model, that can be scaled, warped, and faded to create cosmetic effects (muzzle flashes, debris from weapon impact / explosions)
SimpleObject | -basic 1 part object, used in effects for ejected shells
SpriteParticle | -2d effect that can be scaled, warped, faded, etc... for cosmetic effects


Battlefield Mod Development Tools- Con Guide - Geometry.con

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Geometry.con

This file contains all the geometryTemplate definitions that link the Battlefield 1942 *.sm files to .con *geometry entries that can be used with objects. Typically, this file will have a geometryTemplate entry for each of the geometries found in the objects, physics, and weapons .con files in that directory. The viewable distance, shadow, and other properties can be adjust here as well.

see *GeometryTemplate for more information


MDT Documentation - CON - ObjectTemplate - Intro

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

ObjectTemplate Command

Almost everything in Battlefield 1942 is composed of objects. All weapons, vehicles, plants, buldings, flags, and even players are considered objects. In fact, the only thing that isn't considered an object in Battlefield 1942 is the ground, sky, and water.

There is a pre-defined list of object types that battlefield can use to create new objects. Then the properties for that object can be modified to create custom behaviors for that object.

Complex objects can be created by linking multiple objects together.

ObjectTemplate is used to put all these together to create a template for a new custom object. The object can then be used in the game by calling it in a map, or another object.

Commands - These are the commands used to create new objects, and link them together

Types - List and description of all the different pre-defined object types types in Battlefield 1942, and the properties that can be used on them.

Properties - List and description of all the different properties, and the objects they are valid for.


MDT Documentation - Object Types - AnimatedBundle

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

AnimatedBundle

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - AreaObject

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
AreaObject

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - BFSoldier

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
BFSoldier

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - Bundle

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
Bundle

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - Camera

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
Camera

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - ControlPoint

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
ControlPoint

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - EffectBundle

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
EffectBundle

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - Emitter

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
Emitter

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - Engine

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
Engine

The Engine object in Battlefield 1942 is used to genereate thrust for vehicles, weapons, and other objects. There are six types of engines, specified by the setEngineType property. Land engines generate thrust through child spring objects, while the other engine types generate thrust directly from the engine itself.

The amount of thrust generated depends on multiple properties.

Torque, Differential, Rotation, and Gears.

Torque controls the amount of power an engine has, Differential multiplies the torque for an increase in speed, but a loss of power (climbing ability), while gears control the amount of power applied to the springs.

The rotation (setMaxRotation, setMinRotation, setAcceleration, setMaxSpeed) controls the increment of the throttle (setInputToRoll). Applying the the throttle will increase the rotation of the engine by the amount of acceleration specified until the max rotation is reached.

Child Objects

Most engines usually have child objects added with addTemplate. For land engines, springs or tank tracks are needed to drive on, while planes will usually have a propellor and landing gear.

Examples

Jeep engine:

rem *** WillyEngine ***
ObjectTemplate.create Engine WillyEngine
ObjectTemplate.setNetworkableInfo WillyEngineInfo
ObjectTemplate.setAttachToListener 1
ObjectTemplate.loadSoundScript Sounds/WillyEngine.ssc
ObjectTemplate.hasMobilePhysics 1
ObjectTemplate.hasCollisionPhysics 1
ObjectTemplate.hasResponsePhysics 1
rem -------------------------------------
ObjectTemplate.addTemplate WillyFrontWheelR
ObjectTemplate.setPosition 0.6/0.11/1.0
ObjectTemplate.addTemplate WillyFrontWheelL
ObjectTemplate.setPosition -0.6/0.11/1.0
ObjectTemplate.addTemplate WillyBackSpringR
ObjectTemplate.setPosition 0.6/-0.472/-1.21
ObjectTemplate.addTemplate WillyBackSpringL
ObjectTemplate.setPosition -0.6/-0.472/-1.21
rem -------------------------------------
ObjectTemplate.setMinRotation 0/0/-5000
ObjectTemplate.setMaxRotation 0/0/5000
ObjectTemplate.setMaxSpeed 0/0/55000
ObjectTemplate.setAcceleration 0/0/55000
ObjectTemplate.setInputToRoll c_PIThrottle
ObjectTemplate.setAutomaticReset 1
ObjectTemplate.setEngineType c_ETCar
ObjectTemplate.setTorque 10.5
ObjectTemplate.setDifferential 7
ObjectTemplate.setNumberOfGears 5
ObjectTemplate.setGearUp 0.95
ObjectTemplate.setGearDown 0.4

Plane engine:

rem *** SpitfireEngine ***
ObjectTemplate.create Engine SpitfireEngine
ObjectTemplate.setNetworkableInfo Spitfire_engine_info
ObjectTemplate.loadSoundScript Sounds/SpitfireEngine.ssc
rem -------------------------------------
ObjectTemplate.addTemplate lodSpitfirePropeller
ObjectTemplate.setPosition 0/0.135/-0.799
ObjectTemplate.addTemplate SpitfireLandingGearL
ObjectTemplate.setPosition -0.645/-0.45/-3.543
ObjectTemplate.addTemplate SpitfireLandingGearR
ObjectTemplate.setPosition 0.646/-0.45/-3.543
rem -------------------------------------
ObjectTemplate.setMinRotation -0.3/0/-3000
ObjectTemplate.setMaxRotation 0.3/0/5000
ObjectTemplate.setMaxSpeed 1000/0/500
ObjectTemplate.setAcceleration 500/0/1000
ObjectTemplate.setInputToRoll c_PIThrottle
ObjectTemplate.setAutomaticReset 1
ObjectTemplate.setEngineType c_ETPlane
ObjectTemplate.setTorque 15
ObjectTemplate.setDifferential 5
ObjectTemplate.setGearUp 0.7
ObjectTemplate.setGearDown 0.3
ObjectTemplate.setNoPropellerEffectAtSpeed 70

Valid Properties for this Object

geometry - visible + collision model from GeometryTemplate
hasresponsephysics - can respond to user input
hascollisionphysics - can collide with objects
setgearchangetime - time engine takes to change gears
setnumberofgears - total gears available to engine
setinputtoyaw - bind user input to yaw control
hasmobilephysics - object can move
setattachtolistener - *uncertain
saveinseparatefile - *uncertain
setnopropellereffectatspeed - *uncertain
setgeardown - percentage of total engine rotation that must be reached before engine switches gear down
setgearup - percentage of total engine rotation that must be reached before engine switches gear up
setdifferential - multiplier for torque
settorque - specifies torque (power) for engine
setenginetype - specifies where engine generates thrust (in water, on land, in air)
setautomaticreset - resets the throttle to 0 after input is removed
setinputtoroll - bind user input to throttle control
setacceleration - the increment at which the speed rotation is increased
setmaxspeed - maximum speed that the rotation can increase by
setmaxrotation - maximum rotation possible
setminrotation - mimimus rotation possible
loadsoundscript - attach a soundscript to the engine
setnetworkableinfo - attach a NetworkableInfo to the object for network compatibility


MDT Documentation - Object Types - EntryPoint

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
EntryPoint

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - FireArms

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
FireArms

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - Flag

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
Flag

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - FlagBase

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
FlagBase

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - FloatingBundle

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
FloatingBundle

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - ObjectTypes - FreeCamera

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
FreeCamera

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - HandFireArms

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
HandFireArms

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - Intro

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Battlefield 1942 Object Types

These are the different pre-defined types of objects that can be used with the ObjectTemplate.create command. Each type has different behaviors, and the properties can have different effects (or none at all) depending on the object type.

*Perhaps organize these by some sort of class system? Like Weapons / Effects / Physics / Maps ?

AnimatedBundle *

AreaObject*

BFSoldier*

Bundle*

Camera*

ControlPoint*

EffectBundle*

Emitter*

Engine*

EntryPoint*

FireArms*

Flag*

FlagBase*

FloatingBundle*

FreeCamera*

HandFireArms*

Kit*

KitPart*

LandingGear*

LensFlare*

LodObject*

ObjectSpawner*

Obstacle*

Particle*

PlayerControlObject*

Projectile*

RotationalBundle*

SeatObject*

SimpleObject*

SonarObject*

SpawnPoint*

Spring*

SpriteParticle*

SupplyDepot*

Wing*


MDT Documentation - Object Types - Kit

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
Kit

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - KitPart

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
KitPart

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - LandingGear

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
LandingGear

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - LensFlare

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
LensFlare

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - LodObject

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
LodObject

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - ObjectSpawner

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
ObjectSpawner

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - Obstacle

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
Obstacle

Players can pass through this object, and it can cause damage to soldiers, depending on the Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - Particle

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
Particle

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - PlayerControlObject

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
PlayerControlObject

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - Projectile

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
Projectile

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - RotationalBundle

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
RotationalBundle

A RotationalBundle is an object that can pivot based on user input, or at a continuous speed. It can also have child objects, such as weapons and springs, making it ideal for turrets and steering.

When creating a RotationalBundle, it is common to specify the range of motion (setMaxRotation,setMinRotation), the speed of rotation (setAcceleration, setMaxSpeed), and then bind inputs to the different directions (setInputToYaw, setInputToPitch, setInputToRoll)

Examples

Tank Turret

rem *** TigerTower ***
ObjectTemplate.create RotationalBundle TigerTower
ObjectTemplate.setNetworkableInfo TigerTurretInfo
ObjectTemplate.setAttachToListener 1
ObjectTemplate.loadSoundScript Sounds/tigertower.ssc
ObjectTemplate.geometry Tiger_Tow_M1
ObjectTemplate.hasMobilePhysics 1
ObjectTemplate.hasResponsePhysics 1
ObjectTemplate.hasCollisionPhysics 1
rem -------------------------------------
ObjectTemplate.addTemplate TigerGunBase
ObjectTemplate.setPosition 0/0.325/1.295
ObjectTemplate.addTemplate TigerTowerHatch
ObjectTemplate.setPosition -0.792/0.95/-0.232
rem -------------------------------------
ObjectTemplate.setMaxSpeed 20/25/0
ObjectTemplate.setAcceleration 1000/0/0
ObjectTemplate.setInputToYaw c_PIMouseLookX
Front Turning Wheels for Jeep
rem *** WillyFrontWheelR ***
ObjectTemplate.create RotationalBundle WillyFrontWheelR
ObjectTemplate.setNetworkableInfo WillySteeringInfo
ObjectTemplate.hasMobilePhysics 1
ObjectTemplate.hasCollisionPhysics 1
ObjectTemplate.hasResponsePhysics 1
rem -------------------------------------
ObjectTemplate.addTemplate WillyFrontSpringR
ObjectTemplate.setPosition 0/-0.599/0
rem -------------------------------------
ObjectTemplate.setMinRotation -30/0/0
ObjectTemplate.setMaxRotation 30/0/0
ObjectTemplate.setMaxSpeed 200/0/0
ObjectTemplate.setAcceleration 200/0/0
ObjectTemplate.setInputToYaw c_PIYaw
ObjectTemplate.setAutomaticReset 1

Valid Properties for this Object

automaticpitchstabilization, setautomaticpitchstabilization - help stabilize pitch
automaticyawstabilization, setautomaticyawstabilization - help stabilize yaw
setattachtolistener - *unsure
setnetworkableinfo, networkableinfo - attach a networkinfo for multi-player compatibility
setautomaticreset - Automatically retun to initial position when input is removed
hasresponsephysics - Object responds to user input
hascollisionphysics, sethascollisionphysics - Object can collide with other object (uses collision data from sm file)
hasmobilephysics - Object can move
setinputtoroll, setinputtopitch, setinputtoyaw - used for binding user input to rotation
loadsoundscript - attach a sound script file for sound effects
setcontinousrotationspeed - automatic rotation speed, good for static objects (windmills, radar)
setacceleration - rate the rotation speed increases
setmaxspeed - maximum rotation rate
setpivotposition - shifts the orgin of rotation
setmaxrotation - maximum extent of rotation
setminrotation - minimum extent of rotation
geometry - gemometryTemplate for physical apperance and collision data


MDT Documentation - Object Types - SeatObject

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
SeatObject

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - SimpleObject

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
SimpleObject

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - ObjectTypes - SonarObject

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
SonarObject

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - SpawnPoint

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
SpawnPoint

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - Spring

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
Spring

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - SpriteParticle

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
SpriteParticle

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - ObjectTypes - SupplyDepot

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
SupplyDepot

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Types - Wing

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
Wing

Description

Valid Properties for this Object

Valid Properties


MDT Documentation - Object Properties - active

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
active

PROPDESC

Valid object types

ValidType - Description


MDT Documentation - Object Properties - addAmmoType

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addAmmoType


MDT Documentation - Object Properties - addArmorEffect

Step by step
Video tutorials

Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export
addArmorEffect


MDT Documentation - Object Properties - addArmorEffect

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addArmorEffect


MDT Documentation - Object Properties - addChild

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addChild


MDT Documentation - Object Properties - addDevFire

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addDevFire


MDT Documentation - Object Properties - addDevJump

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addDevJump


MDT Documentation - Object Properties - addDevPitch

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addDevPitch


MDT Documentation - Object Properties - addDevStrafe

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addDevStrafe


MDT Documentation - Object Properties - addDevWalk

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addDevWalk


MDT Documentation - Object Properties - addDevYaw

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addDevYaw


MDT Documentation - Object Properties - addEmitterSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addEmitterSpeed


MDT Documentation - Object Properties - addFireArmsPosition

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addFireArmsPosition


MDT Documentation - Object Properties - addLinePoint

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addLinePoint


MDT Documentation - Object Properties - addPcoPosId

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addPcoPosId


MDT Documentation - Object Properties - addRootSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addRootSpeed


MDT Documentation - Object Properties - addSkeletonIK

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addSkeletonIK


MDT Documentation - Object Properties - addToCollisionGroup

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addToCollisionGroup


MDT Documentation - Object Properties - addVehicleType

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addVehicleType


MDT Documentation - Object Properties - addWeaponIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addWeaponIcon


MDT Documentation - Object Properties - addWorkOnMaterial

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
addWorkOnMaterial


MDT Documentation - Object Properties - aiTemplate

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
aiTemplate


MDT Documentation - Object Properties - alphaOverTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
alphaOverTime


MDT Documentation - Object Properties - alphaTestRef

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
alphaTestRef


MDT Documentation - Object Properties - altFireOnce

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
altFireOnce


MDT Documentation - Object Properties - ammoType

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
ammoType


MDT Documentation - Object Properties - angleMod

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
angleMod


MDT Documentation - Object Properties - animationSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
animationSpeed


MDT Documentation - Object Properties - animationSpeedOverTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
animationSpeedOverTime


MDT Documentation - Object Properties - areaValue

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
areaValue


MDT Documentation - Object Properties - artPos

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
artPos


MDT Documentation - Object Properties - automaticPitchStabilization

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
automaticPitchStabilization


MDT Documentation - Object Properties - automaticYawStabilization

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
automaticYawStabilization


MDT Documentation - Object Properties - autoReload

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
autoReload


MDT Documentation - Object Properties - bindToSkeletonPart

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
bindToSkeletonPart


MDT Documentation - Object Properties - buildSkeleton

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
buildSkeleton


MDT Documentation - Object Properties - buildSkin

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
buildSkin


MDT Documentation - Object Properties - cameraDelayDistance

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
cameraDelayDistance


MDT Documentation - Object Properties - cameraDelayTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
cameraDelayTime


MDT Documentation - Object Properties - canBeRepaiedAsDestroyed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
canBeRepaiedAsDestroyed


MDT Documentation - Object Properties - cantSelectWhenNoAmmo

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
cantSelectWhenNoAmmo


MDT Documentation - Object Properties - center1pHands

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
center1pHands


MDT Documentation - Object Properties - changeWeaponWhenNoAmmo

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
changeWeaponWhenNoAmmo


MDT Documentation - Object Properties - colorRGBAOverTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
colorRGBAOverTime


MDT Documentation - Object Properties - coolDownPerSec

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
coolDownPerSec


MDT Documentation - Object Properties - createNotInGrid

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
createNotInGrid


MDT Documentation - Object Properties - createSkeleton

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
createSkeleton


MDT Documentation - Object Properties - criticalDamage

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
criticalDamage


MDT Documentation - Object Properties - cullRadiusScale

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
cullRadiusScale


MDT Documentation - Object Properties - CVMChase

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
CVMChase


MDT Documentation - Object Properties - CVMExternTrace

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
CVMExternTrace


MDT Documentation - Object Properties - CVMFlyBy

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
CVMFlyBy


MDT Documentation - Object Properties - CVMFrontChase

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
CVMFrontChase


MDT Documentation - Object Properties - CVMInside

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
CVMInside


MDT Documentation - Object Properties - CVMTrace

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
CVMTrace


MDT Documentation - Object Properties - damageFromWater

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
damageFromWater


MDT Documentation - Object Properties - damageType

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
damageType


MDT Documentation - Object Properties - damageWhenLost

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
damageWhenLost


MDT Documentation - Object Properties - deathEffectName

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
deathEffectName


MDT Documentation - Object Properties - delay

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
delay


MDT Documentation - Object Properties - destBlendMode

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
destBlendMode


MDT Documentation - Object Properties - destroyed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
destroyed


MDT Documentation - Object Properties - destroyVehicleWhenNoAmmo

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
destroyVehicleWhenNoAmmo


MDT Documentation - Object Properties - detectionRadius

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
detectionRadius


MDT Documentation - Object Properties - detonateOnWaterCollision

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
detonateOnWaterCollision


MDT Documentation - Object Properties - dieAfterColl

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
dieAfterColl


MDT Documentation - Object Properties - dirBarRotate

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
dirBarRotate


MDT Documentation - Object Properties - dirBarXScale

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
dirBarXScale


MDT Documentation - Object Properties - dirBarYScaleAbove

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
dirBarYScaleAbove


MDT Documentation - Object Properties - dirBarYScaleBelow

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
dirBarYScaleBelow


MDT Documentation - Object Properties - dirBarYScaleMax

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
dirBarYScaleMax


MDT Documentation - Object Properties - dirBarYScaleMin

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
dirBarYScaleMin


MDT Documentation - Object Properties - disableIfEnemyInsideRadius

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
disableIfEnemyInsideRadius


MDT Documentation - Object Properties - disableSpawnPointsOnEnter

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
disableSpawnPointsOnEnter


MDT Documentation - Object Properties - disableWhenLosingControl

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
disableWhenLosingControl


MDT Documentation - Object Properties - disarmMinesDistance

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
disarmMinesDistance


MDT Documentation - Object Properties - distance smallwar.con

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
distance smallwar.con


MDT Documentation - Object Properties - distToMinDamage

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
distToMinDamage


MDT Documentation - Object Properties - distToStartLoseDamage

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
distToStartLoseDamage


MDT Documentation - Object Properties - dontClearTeamOnExit

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
dontClearTeamOnExit


MDT Documentation - Object Properties - drag

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
drag


MDT Documentation - Object Properties - dragOffset

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
dragOffset


MDT Documentation - Object Properties - dragOverTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
dragOverTime


MDT Documentation - Object Properties - emitterSpeedScale

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
emitterSpeedScale


MDT Documentation - Object Properties - enableRadarMode

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
enableRadarMode


MDT Documentation - Object Properties - endEffectTemplate

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
endEffectTemplate


MDT Documentation - Object Properties - exitSpeedMod

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
exitSpeedMod


MDT Documentation - Object Properties - exitTimer

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
exitTimer


MDT Documentation - Object Properties - explodeNearEnemyDistance

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
explodeNearEnemyDistance


MDT Documentation - Object Properties - explosionDamage

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
explosionDamage


MDT Documentation - Object Properties - explosionForceMax

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
explosionForceMax


MDT Documentation - Object Properties - explosionForceMod

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
explosionForceMod


MDT Documentation - Object Properties - explosionRadius

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
explosionRadius


MDT Documentation - Object Properties - fadeAtTimeToLiveAfterDeath

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
fadeAtTimeToLiveAfterDeath


MDT Documentation - Object Properties - fadeOnDist

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
fadeOnDist


MDT Documentation - Object Properties - fireAllAtOnce

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
fireAllAtOnce


MDT Documentation - Object Properties - fireDelay

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
fireDelay


MDT Documentation - Object Properties - fireInCameraDof

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
fireInCameraDof


MDT Documentation - Object Properties - fireingForce

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
fireingForce


MDT Documentation - Object Properties - fireOnce

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
fireOnce


MDT Documentation - Object Properties - flagTemplate

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
flagTemplate


MDT Documentation - Object Properties - forceOnExplosion

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
forceOnExplosion


MDT Documentation - Object Properties - geometry terrain.con

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
geometry terrain.con


MDT Documentation - Object Properties - gravityModifier

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
gravityModifier


MDT Documentation - Object Properties - gravityModifierOverTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
gravityModifierOverTime


MDT Documentation - Object Properties - grip

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
grip


MDT Documentation - Object Properties - GUIIndex

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
GUIIndex


MDT Documentation - Object Properties - hasArmor

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hasArmor


MDT Documentation - Object Properties - hasCollisionEffect

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hasCollisionEffect


MDT Documentation - Object Properties - hasCollisionPhysics

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hasCollisionPhysics


MDT Documentation - Object Properties - hasDynamicShadow

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hasDynamicShadow


MDT Documentation - Object Properties - hasMobilePhysics

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hasMobilePhysics


MDT Documentation - Object Properties - hasOnTimeEffect

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hasOnTimeEffect


MDT Documentation - Object Properties - hasOverDamage

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hasOverDamage


MDT Documentation - Object Properties - hasPointPhysics

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hasPointPhysics


MDT Documentation - Object Properties - hasResponsePhysics

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hasResponsePhysics


MDT Documentation - Object Properties - hasRestrictedExit

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hasRestrictedExit


MDT Documentation - Object Properties - hasStartEffect

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hasStartEffect


MDT Documentation - Object Properties - hasStaticColor

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hasStaticColor


MDT Documentation - Object Properties - healDistance

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
healDistance


MDT Documentation - Object Properties - healFactor

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
healFactor


MDT Documentation - Object Properties - heatAddWhenFire

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
heatAddWhenFire


MDT Documentation - Object Properties - hideDuringFireTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hideDuringFireTime


MDT Documentation - Object Properties - hitpoints

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hitpoints


MDT Documentation - Object Properties - holdObject

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
holdObject


MDT Documentation - Object Properties - hpLostWhileCriticalDamage

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hpLostWhileCriticalDamage


MDT Documentation - Object Properties - hpLostWhileDamageFromWater

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hpLostWhileDamageFromWater


MDT Documentation - Object Properties - hpLostWhileUpSideDown

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
hpLostWhileUpSideDown


MDT Documentation - Object Properties - inertiaModifier

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
inertiaModifier


MDT Documentation - Object Properties - initAnimationFrame

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
initAnimationFrame


MDT Documentation - Object Properties - initRotation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
initRotation


MDT Documentation - Object Properties - intensity

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
intensity


MDT Documentation - Object Properties - intensityAtSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
intensityAtSpeed


MDT Documentation - Object Properties - intensityOverTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
intensityOverTime


MDT Documentation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Battlefield 1942 Object Properties

*Find a method to classify better.. Weapons, physics, maps, etc...

(* = incomplete)

active *
addAmmoType *
addArmorEffect *
addChild *
addDevFire *
addDevJump *
addDevPitch *
addDevStrafe *
addDevWalk *
addDevYaw *
addEmitterSpeed *
addFireArmsPosition *
addLinePoint *
addPcoPosId *
addRootSpeed *
addSkeletonIK *
addToCollisionGroup *
addVehicleType *
addWeaponIcon *
addWorkOnMaterial *
aiTemplate *
alphaOverTime *
alphaTestRef *
altFireOnce *
ammoType *
angleMod *
animationSpeed *
animationSpeedOverTime *
areaValue *
artPos *
automaticPitchStabilization *
automaticYawStabilization *
autoReload *
bindToSkeletonPart *
buildSkeleton *
buildSkin *
cameraDelayTime *
cameraDelayDistance *
canBeRepaiedAsDestroyed *
cantSelectWhenNoAmmo *
center1pHands *
changeWeaponWhenNoAmmo *
colorRGBAOverTime *
coolDownPerSec *
createNotInGrid *
createSkeleton *
criticalDamage *
cullRadiusScale *
CVMChase *
CVMExternTrace *
CVMFlyBy *
CVMFrontChase *
CVMInside *
CVMTrace *
damageFromWater *
damageType *
damageWhenLost *
deathEffectName *
delay *
destBlendMode *
destroyed *
destroyVehicleWhenNoAmmo *
detectionRadius *
detonateOnWaterCollision *
dieAfterColl *
dirBarRotate *
dirBarXScale *
dirBarYScaleAbove *
dirBarYScaleBelow *
dirBarYScaleMax *
dirBarYScaleMin *
disableIfEnemyInsideRadius *
disableSpawnPointsOnEnter *
disableWhenLosingControl *
disarmMinesDistance *
distance smallwar.con *
distToMinDamage *
distToStartLoseDamage *
dontClearTeamOnExit *
drag *
dragOffset *
dragOverTime *
emitterSpeedScale *
enableRadarMode *
endEffectTemplate *
exitSpeedMod *
exitTimer *
explodeNearEnemyDistance *
explosionDamage *
explosionForceMax *
explosionForceMod *
explosionRadius *
fadeAtTimeToLiveAfterDeath *
fadeOnDist *
fireAllAtOnce *
fireDelay *
fireInCameraDof *
fireingForce *
fireOnce *
flagTemplate *
forceOnExplosion *
geometry terrain.con *
gravityModifier *
gravityModifierOverTime *
grip *
GUIIndex *
hasArmor *
hasCollisionEffect *
hasCollisionPhysics *
hasDynamicShadow *
hasMobilePhysics *
hasOnTimeEffect *
hasOverDamage *
hasPointPhysics *
hasResponsePhysics *
hasRestrictedExit *
hasStartEffect *
hasStaticColor *
healDistance *
healFactor *
heatAddWhenFire *
hideDuringFireTime *
hitpoints *
holdObject *
hpLostWhileCriticalDamage *
hpLostWhileDamageFromWater *
hpLostWhileUpSideDown *
inertiaModifier *
initAnimationFrame *
initRotation *
intensity *
intensityAtSpeed *
intensityOverTime *
invisible *
invisibleAtEndEffect *
isPortalPassing *
isSticky (not used in any .con file) *
itemIndex *
loadSoundScript *
lodDistance *
lodSelector *
looping *
loseControlWhenEnemyClose *
loseControlWhenNotClose *
magSize *
magType *
mass *
material *
material2 *
maxDeviation *
maxDist *
maxDistAlpha *
maxDistanceUnderwaterSurface *
maxHitpoints *
maxNrOfObjectSpawned *
maxSpawnDelay *
minDamage *
minDevCrouching *
minDeviation *
minDevLying *
minDevStanding *
minDist *
minDistAlpha *
minDistanceUnderwaterSurface *
minSpawnDelay *
moveToWaterSurface *
name *
nameTagOffset *
networkableInfo *
noCollisionsAsDestroyed *
noFFSound *
noPhysics *
nrOfObjectToSpawn *
numAnimationFrames *
numOfMag *
objectSpawnerId *
onlyTakeableByTeam *
outsideHudOffset *
portalPassingPosition *
positionalSpeedInDof *
positionalSpeedInRight *
positionalSpeedInUp *
projectile2Template *
projectilePosition *
projectileTemplate *
projectileVisible *
proximityFusePrimer *
radius *
recoilSize *
recoilSpeed *
relativePositionInDof *
relativePositionInRight *
relativePositionInUp *
reloadTime *
rememberExcessInput *
repairDistance *
repairFactor *
resetWhenRemoved *
rotationalSpeed *
rotationalSpeedInDof *
rotationalSpeedInRight *
rotationalSpeedInUp *
rotationSpeed *
rotationSpeedOverTime *
roundOfFire *
saveInSeparateFile *
scanForEnemySonars *
seatAnimationLowerBody *
seatAnimationUpperBody *
seatFlags *
selfDestroy *
selfHealFactor *
set1pFov *
setAcceleration *
setActive *
setAIEnterOnSpawn *
setAmmoBar *
setAmmoBarFill *
setAmmoBarSize *
setAmmoIcon *
setAmomBarPosX *
setAmomBarPosY *
setAmomBarTextPosX *
setAmomBarTextPosY *
setAnimatedTextureSpeed *
setAnimationState *
setAsynchronyFire *
setAttachToListener *
setAutomaticPitchStabilization *
setAutomaticReset *
setAutomaticYawStabilization *
setBackFlareCount *
setBoneName *
setBoneOriginOffset *
setCharacterHeight *
setCheckBoneDistance *
setContinousRotationSpeed *
setControlPointIcon *
setControlPointName *
setCopyLinksCount *
setCoronaColor *
setCoronaCount *
setCoronaDestBlend *
setCoronaFadeAll *
setCoronaRot *
setCoronaScale *
setCoronaSize *
setCoronaSrcBlend *
setCoronaTexture *
setCrossHairType *
setDamping *
setDevMod *
setDifferential *
setDragModifier *
setEngineType *
setEnterOnSpawn *
setEntryRadius *
setFireDev *
setFlagLocation *
setFlapLift *
setFlareColor *
setFlareDestBlend *
setFlareDistFadeScale *
setFlareFadeAll *
setFlareRot *
setFlareScale *
setFlareSize *
setFlareSrcBlend *
setFlareTexture *
setFloatMaxLift *
setFloatMinLift *
setGearChangeTime *
setGearDown *
setGearDownEngineInput *
setGearDownHeight *
setGearUp *
setGearUpEngineInput *
setGearUpHeight *
setGoBackOnRecoil *
setGroup *
setHasCollisionPhysics *
setHasMag *
setHasMobilePhysics *
setHasPointPhysics *
setHasRecoilForce *
setHasResponsePhysics *
setHasTarget *
setHasTurretIcon *
setHealth *
setHealthBarFullIcon *
setHealthBarIcon *
setHudAmmoType *
setHullHeight *
setInputFire *
setInputId *
setInputToPitch *
setInputToRoll *
setInputToYaw *
setIsFirstPersonPart *
setKitActiveName *
setKitIcon *
setKitName *
setKitTeam *
setLensFlareCount *
setLiePointUpDownAngle *
setLodValue *
setMaxRotation *
setMaxSpeed *
setMinDev *
setMinimapIcon *
setMinimapIconSize *
setMinRotation *
setMiscDev *
setName *
setNetworkableInfo *
setNoPropellerEffectAtSpeed *
setNumberOfGears *
setNumberOfWeaponIcons *
setObjectTemplate *
setParachuteDrag *
setParachuteSpeed *
setPcoId *
setPitchOffset *
setPivotPosition *
setPointUpDownAngle *
setPoseCameraPos *
setPosition *
setPositionOffset *
setPrimaryAmmoBar *
setPrimaryAmmoIcon *
setRadioLanguage *
setRandomGeometries *
setRecoilForceLeftRight *
setRecoilForceUp *
setRegulateToLift *
setRotation *
setScopeIcon *
setSecondaryAmmoBar *
setSecondaryAmmoIcon *
setSightIcon *
setSinkingSpeedMod *
setSkeletonCollisionBone *
setSniperSight *
setSoldierCrouchIcon *
setSoldierExitLocation *
setSoldierProneIcon *
setSoldierStandingIcon *
setSpawnAsParaTroper *
setSpawnId *
setSpawnPositionOffset *
setSpawnPreventionDelay *
setSpawnPrevetionDelay *
setSpawnRotation *
setSpeedDev *
setStartOnEffects *
setStrength *
setSubmarineHudDepthModifier *
setSubmarineHudDirModifier *
setTeamFlagIcon *
setTeamGeometry *
setTicketIcon *
setToolTipType *
setTorque *
setTracerTemplate *
setTurnDev *
setTurnLeftRightAngle *
setType *
setVehicleCategory *
setVehicleIcon *
setVehicleIconPos *
setVehicleType *
setVisibilityAngleDeg *
setVisibleDummyProjectileTemplate *
setWeaponLink *
setWingLift *
setWingToRegulatorRatio *
showInFirstPerson *
showInThirdPerson *
sinkInToLandAfterDeathSpeed *
size *
sizeModifier *
sizeOverTime *
soldierCameraPosition *
soldierZoomFov *
soldierZoomPosition *
sonarPos *
spawnDelay *
spawnDelayAtStart *
spawnGroupId *
spawnOffset *
speedMod *
srcBlendMode *
startAtCreation *
startEffectTemplate *
startOnEffects *
startProbability *
startRotation *
stayAsDestroyed *
stopAtEndEffect *
subDev *
subDevCrouching *
subDevLying *
subDevStanding *
submarineData *
subPos *
team *
teamOnVehicle *
template *
texture *
timeDelayOnOverHeat *
timeOnEndEffect *
timeToGetControl *
timeToLive *
timeToLiveAfterDeath *
timeToLoseControl *
timeToNotAllowChange *
timeToReSpawn *
timeToStartFadeAfterDeath *
toggleMouseLook *
tracerScaler *
triggerRadius *
turnsInMovingDirection *
unableToChangeTeam *
unZoomBetweenFireTime *
useAsBone *
useButtonRadius *
useMipMap *
useMipMaps *
useMMOnEndEffect *
useScope *
useSkeletonPartAsMain *
useUVRotation *
velocity *
velocityDependentOnHeat *
visibleBarrelTemplate *
visibleDummyProjectileTemplate *
waterDamageDelay *
workOnSoldiers *
workOnVehicles *
XYSizeRatio *
XYSizeRatioOverTime *
YModOnExplosion *
zoomFov *


MDT Documentation - Object Properties - invisible

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
invisible


MDT Documentation - Object Properties - invisibleAtEndEffect

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
invisibleAtEndEffect


MDT Documentation - Object Properties - isPortalPassing

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
isPortalPassing


MDT Documentation - Object Properties - isSticky (not used in any .con file)

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
isSticky (not used in any .con file)


MDT Documentation - Object Properties - itemIndex

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
itemIndex


MDT Documentation - Object Properties - loadSoundScript

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
loadSoundScript


MDT Documentation - Object Properties - lodDistance

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
lodDistance


MDT Documentation - Object Properties - lodSelector

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
lodSelector


MDT Documentation - Object Properties - looping

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
looping


MDT Documentation - Object Properties - loseControlWhenEnemyClose

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
loseControlWhenEnemyClose


MDT Documentation - Object Properties - loseControlWhenNotClose

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
loseControlWhenNotClose


MDT Documentation - Object Properties - magSize

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
magSize


MDT Documentation - Object Properties - magType

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
magType


MDT Documentation - Object Properties - mass

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
mass


MDT Documentation - Object Properties - material

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
material


MDT Documentation - Object Properties - material2

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
material2


MDT Documentation - Object Properties - maxDeviation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
maxDeviation


MDT Documentation - Object Properties - maxDist

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
maxDist


MDT Documentation - Object Properties - maxDistAlpha

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
maxDistAlpha


MDT Documentation - Object Properties - maxDistanceUnderwaterSurface

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
maxDistanceUnderwaterSurface


MDT Documentation - Object Properties - maxHitpoints

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
maxHitpoints


MDT Documentation - Object Properties - maxNrOfObjectSpawned

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
maxNrOfObjectSpawned


MDT Documentation - Object Properties - maxSpawnDelay

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
maxSpawnDelay


MDT Documentation - Object Properties - minDamage

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
minDamage


MDT Documentation - Object Properties - minDevCrouching

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
minDevCrouching


MDT Documentation - Object Properties - minDeviation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
minDeviation


MDT Documentation - Object Properties - minDevLying

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
minDevLying


MDT Documentation - Object Properties - minDevStanding

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
minDevStanding


MDT Documentation - Object Properties - minDist

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
minDist


MDT Documentation - Object Properties - minDistAlpha

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
minDistAlpha


MDT Documentation - Object Properties - minDistanceUnderwaterSurface

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
minDistanceUnderwaterSurface


MDT Documentation - Object Properties - minSpawnDelay

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
minSpawnDelay


MDT Documentation - Object Properties - moveToWaterSurface

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
moveToWaterSurface


MDT Documentation - Object Properties - name

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
name


MDT Documentation - Object Properties - nameTagOffset

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
nameTagOffset


MDT Documentation - Object Properties - networkableInfo

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
networkableInfo


MDT Documentation - Object Properties - noCollisionsAsDestroyed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
noCollisionsAsDestroyed


MDT Documentation - Object Properties - noFFSound

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
noFFSound


MDT Documentation - Object Properties - noPhysics

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
noPhysics


MDT Documentation - Object Properties - nrOfObjectToSpawn

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
nrOfObjectToSpawn


MDT Documentation - Object Properties - numAnimationFrames

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
numAnimationFrames


MDT Documentation - Object Properties - numOfMag

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
numOfMag


MDT Documentation - Object Properties - objectSpawnerId

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
objectSpawnerId


MDT Documentation - Object Properties - onlyTakeableByTeam

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
onlyTakeableByTeam


MDT Documentation - Object Properties - outsideHudOffset

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
outsideHudOffset


MDT Documentation - Object Properties - portalPassingPosition

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
portalPassingPosition


MDT Documentation - Object Properties - positionalSpeedInDof

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
positionalSpeedInDof


MDT Documentation - Object Properties - positionalSpeedInRight

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
positionalSpeedInRight


MDT Documentation - Object Properties - positionalSpeedInUp

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
positionalSpeedInUp


MDT Documentation - Object Properties - projectile2Template

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
projectile2Template


MDT Documentation - Object Properties - projectilePosition

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
projectilePosition


MDT Documentation - Object Properties - projectileTemplate

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
projectileTemplate


MDT Documentation - Object Properties - projectileVisible

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
projectileVisible


MDT Documentation - Object Properties - proximityFusePrimer

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
proximityFusePrimer


MDT Documentation - Object Properties - radius

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
radius


MDT Documentation - Object Properties - recoilSize

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
recoilSize


MDT Documentation - Object Properties - recoilSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
recoilSpeed


MDT Documentation - Object Properties - relativePositionInDof

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
relativePositionInDof


MDT Documentation - Object Properties - relativePositionInRight

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
relativePositionInRight


MDT Documentation - Object Properties - relativePositionInUp

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
relativePositionInUp


MDT Documentation - Object Properties - reloadTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
reloadTime


MDT Documentation - Object Properties - rememberExcessInput

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
rememberExcessInput


MDT Documentation - Object Properties - repairDistance

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
repairDistance


MDT Documentation - Object Properties - repairFactor

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
repairFactor


MDT Documentation - Object Properties - resetWhenRemoved

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
resetWhenRemoved


MDT Documentation - Object Properties - rotationalSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
rotationalSpeed


MDT Documentation - Object Properties - rotationalSpeedInDof

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
rotationalSpeedInDof


MDT Documentation - Object Properties - rotationalSpeedInRight

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
rotationalSpeedInRight


MDT Documentation - Object Properties - rotationalSpeedInUp

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
rotationalSpeedInUp


MDT Documentation - Object Properties - rotationSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
rotationSpeed


MDT Documentation - Object Properties - rotationSpeedOverTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
rotationSpeedOverTime


MDT Documentation - Object Properties - roundOfFire

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
roundOfFire


MDT Documentation - Object Properties - saveInSeparateFile

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
saveInSeparateFile


MDT Documentation - Object Properties - scanForEnemySonars

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
scanForEnemySonars


MDT Documentation - Object Properties - seatAnimationLowerBody

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
seatAnimationLowerBody


MDT Documentation - Object Properties - seatAnimationUpperBody

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
seatAnimationUpperBody


MDT Documentation - Object Properties - seatFlags

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
seatFlags


MDT Documentation - Object Properties - selfDestroy

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
selfDestroy


MDT Documentation - Object Properties - selfHealFactor

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
selfHealFactor


MDT Documentation - Object Properties - set1pFov

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
set1pFov


MDT Documentation - Object Properties - setAcceleration

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAcceleration


MDT Documentation - Object Properties - setActive

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setActive


MDT Documentation - Object Properties - setAIEnterOnSpawn

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAIEnterOnSpawn


MDT Documentation - Object Properties - setAmmoBar

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAmmoBar


MDT Documentation - Object Properties - setAmmoBarFill

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAmmoBarFill


MDT Documentation - Object Properties - setAmmoBarSize

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAmmoBarSize


MDT Documentation - Object Properties - setAmmoIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAmmoIcon


MDT Documentation - Object Properties - setAmomBarPosX

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAmomBarPosX


MDT Documentation - Object Properties - setAmomBarTextPosY

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAmomBarTextPosY


MDT Documentation - Object Properties - setAnimatedTextureSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAnimatedTextureSpeed


MDT Documentation - Object Properties - setAnimationState

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAnimationState


MDT Documentation - Object Properties - setAsynchronyFire

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAsynchronyFire


MDT Documentation - Object Properties - setAttachToListener

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAttachToListener


MDT Documentation - Object Properties - setAutomaticPitchStabilization

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAutomaticPitchStabilization


MDT Documentation - Object Properties - setAutomaticReset

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAutomaticReset


MDT Documentation - Object Properties - setAutomaticYawStabilization

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAutomaticYawStabilization


MDT Documentation - Object Properties - setBackFlareCount

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setBackFlareCount


MDT Documentation - Object Properties - setBoneName

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setBoneName


MDT Documentation - Object Properties - setBoneOriginOffset

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setBoneOriginOffset


MDT Documentation - Object Properties - setCharacterHeight

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCharacterHeight


MDT Documentation - Object Properties - setCheckBoneDistance

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCheckBoneDistance


MDT Documentation - Object Properties - setContinousRotationSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setContinousRotationSpeed


MDT Documentation - Object Properties - setControlPointIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setControlPointIcon


MDT Documentation - Object Properties - setControlPointName

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setControlPointName


MDT Documentation - Object Properties - setCopyLinksCount

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCopyLinksCount


MDT Documentation - Object Properties - setCoronaColor

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCoronaColor


MDT Documentation - Object Properties - setCoronaCount

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCoronaCount


MDT Documentation - Object Properties - setCoronaDestBlend

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCoronaDestBlend


MDT Documentation - Object Properties - setCoronaFadeAll

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCoronaFadeAll


MDT Documentation - Object Properties - setCoronaRot

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCoronaRot


MDT Documentation - Object Properties - setCoronaScale

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCoronaScale


MDT Documentation - Object Properties - setCoronaSize

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCoronaSize


MDT Documentation - Object Properties - setCoronaSrcBlend

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCoronaSrcBlend


MDT Documentation - Object Properties - setCoronaTexture

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCoronaTexture


MDT Documentation - Object Properties - setCrossHairType

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setCrossHairType


MDT Documentation - Object Properties - setDamping

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setDamping


MDT Documentation - Object Properties - setDevMod

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setDevMod


MDT Documentation - Object Properties - setDifferential

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setDifferential


MDT Documentation - Object Properties - setDragModifier

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setDragModifier


MDT Documentation - Object Properties - setEngineType

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setEngineType EngineType

This propert is used in engine objects to specify where the engine will genereate thrust.

EngineType - one of 6 constant values:
c_ETLand - Thrust generated through child spring objects
c_ETTank - Thrust generated through child spring objects, uses 4 springs for "tank style" steering
c_ETPlane - Thrust generated directly from the engine, doesn't work underwater
c_ETSea - Thrust generated directly from the engine, only works underwater
c_ETRocket - Identical to c_ETPlane, except that it does not require input, the engine starts running at creation
c_ETTorpedo - Identical to c_ETSea, except that it does not require input, the engine starts running at creation

Valid object types

engine - sets the type of engine for this object.


MDT Documentation - Object Properties - setEnterOnSpawn

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setEnterOnSpawn


MDT Documentation - Object Properties - setEntryRadius

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setEntryRadius


MDT Documentation - Object Properties - setFireDev

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFireDev


MDT Documentation - Object Properties - setFlagLocation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFlagLocation


MDT Documentation - Object Properties - setFlapLift

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFlapLift


MDT Documentation - Object Properties - setFlareColor

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFlareColor


MDT Documentation - Object Properties - setFlareDestBlend

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFlareDestBlend


MDT Documentation - Object Properties - setFlareDistFadeScale

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFlareDistFadeScale


MDT Documentation - Object Properties - setFlareFadeAll

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFlareFadeAll


MDT Documentation - Object Properties - setFlareRot

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFlareRot


MDT Documentation - Object Properties - setFlareScale

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFlareScale


MDT Documentation - Object Properties - setFlareSize

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFlareSize


MDT Documentation - Object Properties - setFlareSrcBlend

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFlareSrcBlend


MDT Documentation - Object Properties - setFlareTexture

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFlareTexture


MDT Documentation - Object Properties - setFloatMaxLift

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFloatMaxLift


MDT Documentation - Object Properties - setFloatMinLift

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setFloatMinLift


MDT Documentation - Object Properties - setGearChangeTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setGearChangeTime


MDT Documentation - Object Properties - setGearDown

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setGearDown


MDT Documentation - Object Properties - setGearDownEngineInput

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setGearDownEngineInput


MDT Documentation - Object Properties - setGearDownHeight

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setGearDownHeight


MDT Documentation - Object Properties - setGearUp

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setGearUp


MDT Documentation - Object Properties - setGearUpEngineInput

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setGearUpEngineInput


MDT Documentation - Object Properties - setGearUpHeight

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setGearUpHeight


MDT Documentation - Object Properties - setGoBackOnRecoil

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setGoBackOnRecoil


MDT Documentation - Object Properties - setGroup

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setGroup


MDT Documentation - Object Properties - setHasCollisionPhysics

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setHasCollisionPhysics


MDT Documentation - Object Properties - setHasMag

Step by step
Video tutorials

Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export
setHasMag


MDT Documentation - Object Properties - setHasMobilePhysics

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setHasMobilePhysics


MDT Documentation - Object Properties - setHasPointPhysics

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setHasPointPhysics


MDT Documentation - Object Properties - setHasRecoilForce

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setHasRecoilForce


MDT Documentation - Object Properties - setHasResponsePhysics

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setHasResponsePhysics


MDT Documentation - Object Properties - setHasTarget

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setHasTarget


MDT Documentation - Object Properties - setHasTurretIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setHasTurretIcon


MDT Documentation - Object Properties - setHealth

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setHealth


MDT Documentation - Object Properties - setHealthBarFullIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setHealthBarFullIcon


MDT Documentation - Object Properties - setHealthBarIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setHealthBarIcon


MDT Documentation - Object Properties - setHudAmmoType

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setHudAmmoType


MDT Documentation - Object Properties - setHullHeight

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setHullHeight


MDT Documentation - Object Properties - setInputFire

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setInputFire


MDT Documentation - Object Properties - setInputId

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setInputId


MDT Documentation - Object Properties - setInputToPitch

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setInputToPitch


MDT Documentation - Object Properties - setInputToRoll

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setInputToRoll


MDT Documentation - Object Properties - setInputToYaw

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setInputToYaw


MDT Documentation - Object Properties - setIsFirstPersonPart

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setIsFirstPersonPart


MDT Documentation - Object Properties - setKitActiveName

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setKitActiveName


MDT Documentation - Object Properties - setKitIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setKitIcon


MDT Documentation - Object Properties - setKitName

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setKitName


MDT Documentation - Object Properties - setKitTeam

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setKitTeam


MDT Documentation - Object Properties - setLensFlareCount

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setLensFlareCount


MDT Documentation - Object Properties - setLiePointUpDownAngle

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setLiePointUpDownAngle


MDT Documentation - Object Properties - setLodValue

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setLodValue


MDT Documentation - Object Properties - setMaxRotation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setMaxRotation


MDT Documentation - Object Properties - setMaxSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setMaxSpeed


MDT Documentation - Object Properties - setMinDev

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setMinDev


MDT Documentation - Object Properties - setMinimapIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setMinimapIcon


MDT Documentation - Object Properties - setMinimapIconSize

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setMinimapIconSize


MDT Documentation - Object Properties - setMinRotation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setMinRotation


MDT Documentation - Object Properties - setMiscDev

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setMiscDev


MDT Documentation - Object Properties - setName

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setName


MDT Documentation - Object Properties - setNetworkableInfo

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setNetworkableInfo


MDT Documentation - Object Properties - setNoPropellerEffectAtSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setNoPropellerEffectAtSpeed


MDT Documentation - Object Properties - setNumberOfGears

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setNumberOfGears


MDT Documentation - Object Properties - setNumberOfWeaponIcons

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setNumberOfWeaponIcons


MDT Documentation - Object Properties - setObjectTemplate

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setObjectTemplate


MDT Documentation - Object Properties - setParachuteDrag

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setParachuteDrag


MDT Documentation - Object Properties - setParachuteSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setParachuteSpeed


MDT Documentation - Object Properties - setPcoId

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setPcoId


MDT Documentation - Object Properties - setPitchOffset

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setPitchOffset


MDT Documentation - Object Properties - setPivotPosition

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setPivotPosition


MDT Documentation - Object Properties - setPointUpDownAngle

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setPointUpDownAngle


MDT Documentation - Object Properties - setPoseCameraPos

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setPoseCameraPos


MDT Documentation - Object Properties - setPosition

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setPosition


MDT Documentation - Object Properties - setPositionOffset

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setPositionOffset


MDT Documentation - Object Properties - setPrimaryAmmoBar

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setPrimaryAmmoBar


MDT Documentation - Object Properties - setPrimaryAmmoIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setPrimaryAmmoIcon


MDT Documentation - Object Properties - setRadioLanguage

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setRadioLanguage


MDT Documentation - Object Properties - setRandomGeometries

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setRandomGeometries


MDT Documentation - Object Properties - setRecoilForceLeftRight

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setRecoilForceLeftRight


MDT Documentation - Object Properties - setRecoilForceUp

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setRecoilForceUp


MDT Documentation - Object Properties - setRegulateToLift

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setRegulateToLift


MDT Documentation - Object Properties - setRotation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setRotation


MDT Documentation - Object Properties - setScopeIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setScopeIcon


MDT Documentation - Object Properties - setSecondaryAmmoBar

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSecondaryAmmoBar


MDT Documentation - Object Properties - setSecondaryAmmoIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSecondaryAmmoIcon


MDT Documentation - Object Properties - setSightIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSightIcon


MDT Documentation - Object Properties - setSinkingSpeedMod

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSinkingSpeedMod


MDT Documentation - Object Properties - setSkeletonCollisionBone

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSkeletonCollisionBone


MDT Documentation - Object Properties - setSniperSight

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSniperSight


MDT Documentation - Object Properties - setSoldierCrouchIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSoldierCrouchIcon


MDT Documentation - Object Properties - setSoldierExitLocation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSoldierExitLocation


MDT Documentation - Object Properties - setSoldierProneIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSoldierProneIcon


MDT Documentation - Object Properties - setSoldierStandingIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSoldierStandingIcon


MDT Documentation - Object Properties - setSpawnAsParaTroper

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSpawnAsParaTroper


MDT Documentation - Object Properties - setSpawnId

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSpawnId


MDT Documentation - Object Properties - setSpawnPositionOffset

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSpawnPositionOffset


MDT Documentation - Object Properties - setSpawnPreventionDelay

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSpawnPreventionDelay


MDT Documentation - Object Properties - setSpawnPrevetionDelay

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSpawnPrevetionDelay


MDT Documentation - Object Properties - setSpawnRotation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSpawnRotation


MDT Documentation - Object Properties - setSpeedDev

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSpeedDev


MDT Documentation - Object Properties - setStartOnEffects

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setStartOnEffects


MDT Documentation - Object Properties - setStrength

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setStrength


MDT Documentation - Object Properties - setSubmarineHudDepthModifier

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSubmarineHudDepthModifier


MDT Documentation - Object Properties - setSubmarineHudDirModifier

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setSubmarineHudDirModifier


MDT Documentation - Object Properties - setTeamFlagIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setTeamFlagIcon


MDT Documentation - Object Properties - setTeamGeometry

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setTeamGeometry


MDT Documentation - Object Properties - setTicketIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setTicketIcon


MDT Documentation - Object Properties - setToolTipType

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setToolTipType


MDT Documentation - Object Properties - setTorque

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setTorque


MDT Documentation - Object Properties - setTracerTemplate

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setTracerTemplate


MDT Documentation - Object Properties - setTurnDev

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setTurnDev


MDT Documentation - Object Properties - setTurnLeftRightAngle

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setTurnLeftRightAngle


MDT Documentation - Object Properties - setType

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setType


MDT Documentation - Object Properties - setVehicleCategory

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setVehicleCategory


MDT Documentation - Object Properties - setVehicleIcon

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setVehicleIcon


MDT Documentation - Object Properties - setVehicleIconPos

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setVehicleIconPos


MDT Documentation - Object Properties - setVehicleType

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setVehicleType


MDT Documentation - Object Properties - setVisibilityAngleDeg

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setVisibilityAngleDeg


MDT Documentation - Object Properties - setVisibleDummyProjectileTemplate

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setVisibleDummyProjectileTemplate


MDT Documentation - Object Properties - setWeaponLink

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setWeaponLink


MDT Documentation - Object Properties - setWingLift

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setWingLift


MDT Documentation - Object Properties - setWingToRegulatorRatio

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setWingToRegulatorRatio


MDT Documentation - Object Properties - showInFirstPerson

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
showInFirstPerson


MDT Documentation - Object Properties - showInThirdPerson

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
showInThirdPerson


MDT Documentation - Object Properties - sinkInToLandAfterDeathSpeed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
sinkInToLandAfterDeathSpeed


MDT Documentation - Object Properties - size

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
size


MDT Documentation - Object Properties - sizeModifier

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
sizeModifier


MDT Documentation - Object Properties - sizeOverTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
sizeOverTime


MDT Documentation - Object Properties - soldierCameraPosition

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
soldierCameraPosition


MDT Documentation - Object Properties - soldierZoomFov

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
soldierZoomFov


MDT Documentation - Object Properties - soldierZoomPosition

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
soldierZoomPosition


MDT Documentation - Object Properties - sonarPos

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
sonarPos


MDT Documentation - Object Properties - spawnDelay

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
spawnDelay


MDT Documentation - Object Properties - spawnDelayAtStart

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
spawnDelayAtStart


MDT Documentation - Object Properties - spawnGroupId

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
spawnGroupId


MDT Documentation - Object Properties - spawnOffset

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
spawnOffset


MDT Documentation - Object Properties - speedMod

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
speedMod


MDT Documentation - Object Properties - srcBlendMode

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
srcBlendMode


MDT Documentation - Object Properties - startAtCreation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
startAtCreation


MDT Documentation - Object Properties - startEffectTemplate

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
startEffectTemplate


MDT Documentation - Object Properties - startOnEffects

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
startOnEffects


MDT Documentation - Object Properties - startProbability

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
startProbability


MDT Documentation - Object Properties - startRotation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
startRotation


MDT Documentation - Object Properties - stayAsDestroyed

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
stayAsDestroyed


MDT Documentation - Object Properties - stopAtEndEffect

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
stopAtEndEffect


MDT Documentation - Object Properties - subDev

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
subDev


MDT Documentation - Object Properties - subDevCrouching

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
subDevCrouching


MDT Documentation - Object Properties - subDevLying

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
subDevLying


MDT Documentation - Object Properties - subDevStanding

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
subDevStanding


MDT Documentation - Object Properties - submarineData

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
submarineData


MDT Documentation - Object Properties - subPos

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
subPos


MDT Documentation - Object Properties - team

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
team


MDT Documentation - Object Properties - teamOnVehicle

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
teamOnVehicle


MDT Documentation - Object Properties - template

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
template


MDT Documentation - Object Properties - texture

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
texture


MDT Documentation - Object Properties - timeDelayOnOverHeat

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
timeDelayOnOverHeat


MDT Documentation - Object Properties - timeOnEndEffect

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
timeOnEndEffect


MDT Documentation - Object Properties - timeToGetControl

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
timeToGetControl


MDT Documentation - Object Properties - timeToLive

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
timeToLive


MDT Documentation - Object Properties - timeToLiveAfterDeath

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
timeToLiveAfterDeath


MDT Documentation - Object Properties - timeToLoseControl

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
timeToLoseControl


MDT Documentation - Object Properties - timeToNotAllowChange

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
timeToNotAllowChange


MDT Documentation - Object Properties - timeToReSpawn

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
timeToReSpawn


MDT Documentation - Object Properties - timeToStartFadeAfterDeath

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
timeToStartFadeAfterDeath


MDT Documentation - Object Properties - toggleMouseLook

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
toggleMouseLook


MDT Documentation - Object Properties - tracerScaler

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
tracerScaler


MDT Documentation - Object Properties - triggerRadius

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
triggerRadius


MDT Documentation - Object Properties - turnsInMovingDirection

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
turnsInMovingDirection


MDT Documentation - Object Properties - unableToChangeTeam

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
unableToChangeTeam


MDT Documentation - Object Properties - unZoomBetweenFireTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
unZoomBetweenFireTime


MDT Documentation - Object Properties - useAsBone

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
useAsBone


MDT Documentation - Object Properties - useButtonRadius

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
useButtonRadius


MDT Documentation - Object Properties - useMipMap

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
useMipMap


MDT Documentation - Object Properties - useMipMaps

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
useMipMaps


MDT Documentation - Object Properties - useMMOnEndEffect

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
useMMOnEndEffect


MDT Documentation - Object Properties - useScope

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
useScope


MDT Documentation - Object Properties - useSkeletonPartAsMain

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
useSkeletonPartAsMain


MDT Documentation - Object Properties - useUVRotation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
useUVRotation


MDT Documentation - Object Properties - velocity

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
velocity


MDT Documentation - Object Properties - velocityDependentOnHeat

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
velocityDependentOnHeat


MDT Documentation - Object Properties - visibleBarrelTemplate

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
visibleBarrelTemplate


MDT Documentation - Object Properties - visibleDummyProjectileTemplate

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
visibleDummyProjectileTemplate


MDT Documentation - Object Properties - waterDamageDelay

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
waterDamageDelay


MDT Documentation - Object Properties - workOnSoldiers

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
workOnSoldiers


MDT Documentation - Object Properties - workOnVehicles

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
workOnVehicles


MDT Documentation - Object Properties - XYSizeRatio

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
XYSizeRatio


MDT Documentation - Object Properties - XYSizeRatioOverTime

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
XYSizeRatioOverTime


MDT Documentation - Object Properties - YModOnExplosion

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
YModOnExplosion


MDT Documentation - Object Properties - zoomFov

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
zoomFov


MDT Documentation - Object Properties - setAmomBarPosY

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAmomBarPosY


MDT Documentation - Object Properties - setAmomBarTextPosX

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact
setAmomBarTextPosX


MDT Documentation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

ObjectTemplate.addTemplate ObjectName

This command is used to attach a child object to another object. Any ObjectTemplate.setPosition and ObjectTemplate.setRotation commands following this will apply to the attached object, until another ObjectTemplate.addTemplate command is encountered.

ObjectName - Name of the object to be attached, same name as used in ObjectTemplate.create.


MDT Documentation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

ObjectTemplate.Create ObjectType ObjectName

The create command is used to inform the scripting engine that a new object template is going to be created. All properties and commands following a create command will be applied to that object, until another create command or the end of the file is encountered.

ObjectType - This parameter should be one of the pre-defined object types that is going to be created.

ObjectName - This parameter is the new "name" of the object. This is what is used to add this object to other objects with the ObjectTemplate.addTemplate command, and any other object refrences.


MDT Documentation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

ObjectTemplate Commands

These are the commands that ObjectTemplate uses to create, link, and position objects

ObjectTemplate.create - Creates new object from a pre-defined type. All properties and commands following this command will apply to this object.

ObjectTemplate.addTemplate - Adds a child object defined elsewhere to this object.

ObjectTemplate.setPosition - Adjusts the position of the child object.

ObjectTemplate.setRotation - Adjusts the angle / direction of the child object.


MDT Documentation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

ObjectTemplate.setPosition ObjectPosition

This command sets the position of a child object attached to the current object with the ObjectTemplate.addTemplate command. This position is relative to the center of the parent object. If this command is ommited, the position will be at 0/0/0

ObjectPosition - X/Y/Z coordinates of the new position, using standard Battlefield 1942 position coordinates *link.


MDT Documentation

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

ObjectTemplate.setRotation ObjectRotation

This command sets the direction and angles of a child object attached to the current object with the ObjectTemplate.addTemplate command. This angle is relative to the center of the parent object. If this command is ommited, the angles will be at 0/0/0.

ObjectRotation - Yaw / Pitch / Roll degrees of the child object, using the standard Battlefield 1942 rotational degrees *link.


MDT Documentation - Animation - Intro

Step by step
Video tutorials

Tools Guide
Standard Mesh Export
Standard Mesh Import
Tree Mesh Export
Animation Export
Skeleton/Skin Export

BF1942 Scripting
Downloads
Forums
Contact

Introduction to Animation in Battlefield 1942

Animation overview - what is an animation? Bones, States, ect..

Files involved w/ animation - BIK, SKE, SKN, CON...